[SciPy-user] egg dependency?

Robert Kern robert.kern at gmail.com
Fri Dec 2 15:52:53 CST 2005


Andrew Straw wrote:
> I'd like to ask another question regarding eggs -- is there an
> incantation to use for pkg_resources.require() to request only a certain
> version of scipy? This would be great.

If you have the old scipy installed as an egg, and scipy_core and the
new scipy installed as eggs, too, then to select the old version:

  pkg_resources.require('scipy-complete')

To select the new version:

  pkg_resources.require('scipy-core')
  pkg_resources.require('SciPy')

We really should fix the capitalization in the full scipy setup.py .

-- 
Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter



More information about the SciPy-user mailing list