[SciPy-user] scipy 0.4.3, gnuplot and wxPython

jaonary@free.fr jaonary at free.fr
Thu Dec 8 09:20:30 CST 2005


Hi all,

I'm trying to use scipy to do some 2d graphics plotting. I run it under win xp
sp2   with activepython 2.4.2, scipy_core 0.6 and scipy 0.4.3. All of these
intalled using the windows installer available on sourceforge. It said, some
where in the scipy web page, that on windows platform, gnuplot is installed
automaticly by scipy. But, when I do

   from scipy import gplt

I get

 Importing io to scipy
 Importing fftpack to scipy
 Importing special to scipy
 Importing utils to scipy
 Importing cluster to scipy
 Importing sparse to scipy
 Importing interpolate to scipy
 Importing lib to scipy
 Importing integrate to scipy
 Importing signal to scipy
 Importing optimize to scipy
 Importing linalg to scipy
 Importing stats to scipy
 Traceback (most recent call last):
   File "<interactive input>", line 1, in ?
 ImportError: cannot import name gplt

So I think that, there's no gnuplot installed at all! After some tour on the
scipy tutorial, I find that I can plot graphics using wxPython. Great! It makes
me happy. Then, I download the wxPython installer (2.6.1.0) and install it.
But, ....

>>> gui_thread
Traceback (most recent call last):
  File "<interactive input>", line 1, in ?
NameError: name 'gui_thread' is not defined

Arrrgggg!

Any hint will be helpfull. Thank you.



More information about the SciPy-user mailing list