[SciPy-user] Bug in inversematrixcalculation for "scipy_core-0.8.4.win32-py2.3.exe"

Travis Oliphant oliphant.travis at ieee.org
Thu Dec 15 01:56:03 CST 2005


Randewijk P-J <pjrandew at sun.ac.za> wrote:

>Oops,
>
>My platform is winXP, py2.3 using the following binaries: 
>
>scipy_core-0.8.4.win32-py2.3.exe
>and
>scipy-0.4.3.win32-py2.3.exe
>  
>

Ah, yes.  That's the problem.   The new scipy_core is binary 
incompatible with its previous C-API (that's one reason for the bump in 
version numbers).  All compiled extensions must be rebuilt.  This means 
the old scipy-0.4.3 binary will not work but give problems like you 
encountered.

It might be possible to catch this kind of error and warn the user 
before they encounter a segfault.   David Cooke is working on it.  

Full scipy needs to be re-compiled and a new binary made.  I would 
really appreciate the help from other users to make binary releases of 
full scipy (which takes a bit longer to compile...)

I'm going to make another release of scipy core and at that point I will 
make a binary of full scipy available as well.

-Travis



More information about the SciPy-user mailing list