[SciPy-user] Failed Build from SVN

Robert Kern robert.kern at gmail.com
Thu Dec 15 23:00:06 CST 2005


Frank wrote:
> Thanks, Robert. Although I was able to build and install the SVN  
> version of scipy by following your suggestion, I am still unable to  
> get to most of the subpackages (such as interpolate) to import.
> 
> Any ideas why only some are not imported while others are?

We haven't fully implemented the postponed import framework that used to be in
the old scipy. Try importing those subpackages directly ("from scipy import
interpolate").

Personally, I'm -1 on adding the postponed imports. With a few exceptions,
messing with the import machinery tends to cause headaches more than it cures
them, in my experience.

-- 
Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter



More information about the SciPy-user mailing list