[SciPy-user] Packaging Changes to Core in SVN

Robert Kern robert.kern at gmail.com
Sun Dec 25 22:17:40 CST 2005


Travis Oliphant wrote:
> Robert Kern wrote:
> 
>>Travis Oliphant wrote:
>>
>>>Hi folks and Merry Christmas,
>>>
>>>I hope this is the last of the major changes to the scipy core 
>>>structure.  After playing around with various alternative homes for the 
>>>fft, linear algebra, and random number routines, I think (with Robert's 
>>>suggestiong) we've found a permanent home for them under
>>>
>>>scipy.corefft
>>>scipy.corelinalg
>>>scipy.corerandom
>>
>>We don't have any "enhanced" scipy.random, so I think we can leave the
>>scipy_core version as scipy.random. I think that anything that might fit into
>>there in full scipy will either deserve its own subpackage (scipy.mcmc,
>>scipy.aesprng) or will fit comfortably into scipy.stats. We only moved it under
>>scipy.basic because it was an "orphan" module rather than a package. That's no
>>longer a problem.
> 
> That's probably a good idea.  Although there's a certain symmetry to the 
> naming in SVN, I'm not wedded to it.   I think keeping it a package is a 
> good idea for now so we can possibly move mtrand underneath it and get 
> rid of lib from scipy_core.  I'm waiting for more feedback on that idea 
> before doing anything though.

Oh yes, keep it as a package. It should just be named scipy.random, not
scipy.corerandom since it isn't at all analogous to the other two packages.

-- 
Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter



More information about the SciPy-user mailing list