[SciPy-user] using with with blitz: errors

Evan Monroig evan.monroig at gmail.com
Sat Dec 31 01:03:33 CST 2005


On Dec.30 23h58, Fernando Perez wrote :
> Evan Monroig wrote:
> > Hi,
> > 
> > I am trying to use weave to speed up my code with inline c++ code, but 
> > I can't find any working sample.
> > [snip]
> > 
> > gcc version is 4.0.2
>    ^^^^^^^^^^^^^^^^^^^^
> 
> This is your problem: only blitz 0.9 compiles with gcc4.  You need to download 
>   the newer blitz, and put it by hand in the
> 
> /usr/lib/python2.4/site-packages/weave/blitz-20001213/blitz
> 
> directory.

Thanks !

In fact after I checked my gcc version I just installed gcc-3.4 and 
changed the link in /usr/bin and it worked ^^.

So I will get the newer blitz :).

By the way, is there a way to specify the version of gcc to use with 
weave?

Evan
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://www.scipy.net/pipermail/scipy-user/attachments/20051231/e9e47c0a/attachment.bin


More information about the SciPy-user mailing list