[SciPy-user] installation failed on a Intel 64 bit chip

Stephen Walton stephen.walton at csun.edu
Tue Feb 1 18:25:30 CST 2005


eileen ye wrote:

> Sorry to bother you.  I am trying install scipy on a Redhat 64 
> bit linux machine.
>  ...
> gcc -shared build/temp.linux-x86_64-2.2/lapack_litemodule.o 
> -L/usr/lib/atlas -llapack -lcblas -lf77blas -latlas -lg2c -o 
> build/lib.linux-x86_64-2.2/lapack_lite.so
> /usr/bin/ld: 
> /usr/lib/gcc-lib/x86_64-redhat-linux/3.2.3/../../../libf77blas.a(sgbmv.o):

                                                                  ^^^^^^^^^

This is your problem.  The libf77blas.a which is being accessed is the 
one in the RedHat lapack RPM instead of the one for ATLAS.  You'll have 
to uninstall it:

rpm -e lapack octave

since, if I recall, octave depends on lapack.



More information about the SciPy-user mailing list