[SciPy-user] wxpython

Howey, David A d.howey at imperial.ac.uk
Wed Jul 13 07:35:21 CDT 2005


I've now installed wxpython, and sadly get:

>>> import gui_thread
>>> gui_thread.start()

Traceback (most recent call last):
  File "<pyshell#1>", line 1, in -toplevel-
    gui_thread.start()
  File "C:\Python23\Lib\site-packages\gui_thread\__init__.py", line 73,
in start
    wxPython_thread()
  File "C:\Python23\Lib\site-packages\gui_thread\wxPython_thread.py",
line 160, in wxPython_thread
    sys.modules[name] = wrap_extmodule(module,call_holder)
  File "C:\Python23\Lib\site-packages\gui_thread\wxPython_thread.py",
line 61, in wrap_extmodule
    raise NotImplementedError,`t`
NotImplementedError: <type 'PyCObject'>
>>> 
 

Perhaps I've done something wrong?
Dave

-----Original Message-----
From: scipy-user-bounces at scipy.net [mailto:scipy-user-bounces at scipy.net]
On Behalf Of Brice Thurin
Sent: 13 July 2005 13:12
To: SciPy Users List
Subject: Re: [SciPy-user] wxpython

Hi,

I had some trouble in the past as well using gui_thread and someone
recommend me to use matplotlib (http://matplotlib.sourceforge.net).  
Otherwise, wxpython allows you to play with gui and can be find here:  
(http://www.wxpython.org).

Brice



More information about the SciPy-user mailing list