[SciPy-user] Installing SciPy on Mac OS X Tiger

Zhiwen Chong zhiwen.chong at elf.mcgill.ca
Wed Jun 8 15:26:42 CDT 2005


Hi folks,

I was wondering if anyone could help me with my little problem here.

I can't seem to get latest SciPy to build on my Apple machine. I  
suspect it's because I am running Tiger. I've looked on the web for  
solutions, but none of them work, so I am writing to see if anyone  
has any idea what's going on.

1) I'm building SciPy 0.3.2 from the tarball, with the following  
components:
     - Numeric 24.0
     - Apple Developer Tools with X11 developer libraries (Xcode 2.0)
     - gcc 3.3 (I did a 'sudo gcc_select 3.3' because Mac OS X comes  
with gcc 4.0)
     - g77 3.4 (from Guarav Khanna's HPC webpage)
     - FFTW 2.1.5
     - F2PY 2.45.241_1926

2) I wanted the sparse package, so I left this block as it was:
     ignore_packages = [
      #
     ]
    The #define NO_IMPORT_ARRAY was already in the _superluobject.c,  
so I left it as it was.

3) With that, I ran 'python setup.py build'

4) I got an error which somehow seems related to the g77 linker. So I  
downloaded cctools-528.dmg and installed that.

5) It didn't work. The critical error seems to be this one:

/usr/local/bin/g77 -lcc_dynamic -bundle build/temp.darwin-8.1.0- 
Power_Macintosh-2.4/build/src/Lib/fftpack/_fftpackmodule.o build/ 
temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/fftpack/src/zfft.o build/ 
temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/fftpack/src/drfft.o build/ 
temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/fftpack/src/zrfft.o build/ 
temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/fftpack/src/zfftnd.o build/ 
temp.darwin-8.1.0-Power_Macintosh-2.4/build/src/fortranobject.o -L/ 
usr/local/lib -L/usr/local/lib/gcc/powerpc-apple-darwin6.8/3.4.2 - 
Lbuild/temp.darwin-8.1.0-Power_Macintosh-2.4 -ldfftpack -lrfftw - 
lfftw -lg2c -o build/lib.darwin-8.1.0-Power_Macintosh-2.4/scipy/ 
fftpack/_fftpack.so

/usr/bin/ld: can't locate file for: -lcc_dynamic
collect2: ld returned 1 exit status
/usr/bin/ld: can't locate file for: -lcc_dynamic
collect2: ld returned 1 exit status
error: Command "/usr/local/bin/g77 -lcc_dynamic -bundle build/ 
temp.darwin-8.1.0-Power_Macintosh-2.4/build/src/Lib/fftpack/ 
_fftpackmodule.o build/temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/ 
fftpack/src/zfft.o build/temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/ 
fftpack/src/drfft.o build/temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/ 
fftpack/src/zrfft.o build/temp.darwin-8.1.0-Power_Macintosh-2.4/Lib/ 
fftpack/src/zfftnd.o build/temp.darwin-8.1.0-Power_Macintosh-2.4/ 
build/src/fortranobject.o -L/usr/local/lib -L/usr/local/lib/gcc/ 
powerpc-apple-darwin6.8/3.4.2 -Lbuild/temp.darwin-8.1.0- 
Power_Macintosh-2.4 -ldfftpack -lrfftw -lfftw -lg2c -o build/ 
lib.darwin-8.1.0-Power_Macintosh-2.4/scipy/fftpack/_fftpack.so"  
failed with exit status 1

I can't figure out what it means. It seems related to this problem:
http://sourceforge.net/mailarchive/message.php?msg_id=11853060
But I already did a gcc_select 3.3, and I'm not using fink.

I checked my build path -- no spaces in directory names or anything  
like that (which sometimes cause builds to fail).

I also tried building SciPy from the CVS sources, but same deal.

If anyone has any insights into this problem, I'd appreciate it if  
you could share it with me. Thanks a lot for your time!

Zhiwen

Dept. of Chemical Engineering
McMaster University
Hamilton, ON, Canada  L8S 4L7
Tel:   (905) 525-9140  Ext. 24951
FAX: (905) 521-1350
macc.mcmaster.ca




More information about the SciPy-user mailing list