[SciPy-user] bdist-rpm problem

Fernando Perez Fernando.Perez at colorado.edu
Thu Mar 3 19:22:54 CST 2005


Stephen Walton wrote:
> Hi, All,
> 
> A week or so ago, I posted to matplotlib-users about a problem with 
> bdist_rpm.  I'd asked about python 2.3 on Fedora Core 1.
> 
> It turns out there are two problems.  One is that even if one has 
> python2.3 and python2.2 installed, bdist_rpm always calls the 
> interpreter named 'python', which is 2.2 on FC1.  The other problem is 

You need to 'fix' the python version to be called inside the actual rpm build. 
  From the ipython release script:

# A 2.4-specific RPM, where we must use the --fix-python option to ensure that
# the resulting RPM is really built with 2.4 (so things go to
# lib/python2.4/...)
python2.4 ./setup.py bdist_rpm --release=py24 --fix-python

> that in bdist_rpm.py there is a set of lines near line 307 which tests 
> if the number of generated RPM files is 1.  This fails because all of 
> matplotlib, numeric, numarray and scipy generate a debuginfo RPM when 
> one does 'python setup.py bdist_rpm'.  (Why the RPM count doesn't fail 
> with Python 2.3 on FC3 is beyond me, but nevermind.)  The patch is at

This problem has been fixed in recent 2.3 and 2.4.  2.2 still has it.

Best,

f



More information about the SciPy-user mailing list