[SciPy-user] stats newbie question

r help r_hlp at yahoo.com
Thu Mar 17 15:21:15 CST 2005


hi

it is version 0.3.2.  however ive looked over the
debian bug system and this error has been logged
against the debian package python2.3-scipy.  it has
been closed; the problem is that the fix hasnt
propagated down to my distribution yet, so this is not
a problem with scipy but with the debian package.  the
fix is simply to comment out 'import pstats' in
stats/__init__.py, which ive done and so far it seems
to work.  thanks anyway!

-gong

--- Travis Oliphant <oliphant at ee.byu.edu> wrote:
> r help wrote:
> 
> >here they are:
> >
> >
> >Python 2.3.5 (#2, Feb  9 2005, 00:38:15) 
> >[GCC 3.3.5 (Debian 1:3.3.5-8)] on linux2
> >Type "help", "copyright", "credits" or "license"
> for
> >more information.
> >  
> >
> >>>>from scipy import *
> >>>>stats.lognorm.cdf(1,1)
> >>>>        
> >>>>
> >Traceback (most recent call last):
> >  File "<stdin>", line 1, in ?
> >  File
>
>"/usr/lib/python2.3/site-packages/scipy_base/ppimport.py",
> >line 303, in __getattr__
> >    module = self._ppimport_importer()
> >  File
>
>"/usr/lib/python2.3/site-packages/scipy_base/ppimport.py",
> >line 273, in _ppimport_importer
> >    module = __import__(name,None,None,['*'])
> >  File
>
>"/usr/lib/python2.3/site-packages/scipy/stats/__init__.py",
> >line 7, in ?
> >    import pstats
> >ImportError: No module named pstats
> >  
> >
> >
> >
> >  
> >
> This looks like a package installation problem. 
> Could you tell us what version of scipy you are
> running?
> 
> type
> 
> scipy.__version__
> 
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user
> 


		
__________________________________ 
Do you Yahoo!? 
Yahoo! Small Business - Try our new resources site!
http://smallbusiness.yahoo.com/resources/ 



More information about the SciPy-user mailing list