[SciPy-user] building scipy

Jens Brandenburg jens_brandenburg at gmx.net
Thu Nov 10 14:14:46 CST 2005


hello again,

after successful building and installing (thank's a lot Ken) SciPy on 
SUSE 10 OSS (gcc-4.0.2*) a simple ">>>t=scipy.test()" gives me the 
following:

ERROR: check_sh_legendre (scipy.special.basic.test_basic.test_sh_legendre)
----------------------------------------------------------------------
Traceback (most recent call last):
  File 
"/usr/local/lib/python2.3/site-packages/scipy/special/tests/test_basic.py", 
line 1806, in check_sh_legendre
    Ps1 = sh_legendre(1)
  File 
"/usr/local/lib/python2.3/site-packages/scipy/special/orthogonal.py", 
line 593, in sh_legendre
    x,w,mu0 = ps_roots(n,mu=1)
  File 
"/usr/local/lib/python2.3/site-packages/scipy/special/orthogonal.py", 
line 584, in ps_roots
    return js_roots(n,1.0,1.0,mu=mu)
  File 
"/usr/local/lib/python2.3/site-packages/scipy/special/orthogonal.py", 
line 205, in js_roots
    val = gen_roots_and_weights(n,an_Js,sbn_Js,mu0)
  File 
"/usr/local/lib/python2.3/site-packages/scipy/special/orthogonal.py", 
line 121, in gen_roots_and_weights
    eig = get_eig_func()
  File 
"/usr/local/lib/python2.3/site-packages/scipy/special/orthogonal.py", 
line 91, in get_eig_func
    eig = scipy.linalg.eig
AttributeError: 'module' object has no attribute 'eig'

----------------------------------------------------------------------
Ran 747 tests in 1.391s

FAILED (errors=15)

Looks like something's wrong with orthogonal.py... but I'm not too sure 
about this AttributeError. 'eig' is a function, isn't it? Any suggestions?

Thank's so far

Jens



More information about the SciPy-user mailing list