[SciPy-user] installing scipy with python2.4 (Suse10)

Nils Wagner nwagner at mecha.uni-stuttgart.de
Thu Nov 24 02:27:05 CST 2005


Eric Emsellem wrote:
>Hi,
>I am desesperately trying to install scipy. I tried many things but 
>always hit a wall. The last obstacle now is that I get the error:
>#######################################
>gcc options: '-pthread -fno-strict-aliasing -DNDEBUG -O2 -march=i586 
>-mtune=i686 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -g -fPIC'
>compile options: '-Ibuild/src -I/usr/include/python2.4 -c'
>gcc: build/src/Lib/interpolate/dfitpackmodule.c
>build/src/Lib/interpolate/dfitpackmodule.c: In function 
>‘f2py_rout_dfitpack_surfit_smth’:
>build/src/Lib/interpolate/dfitpackmodule.c:2528: error: invalid storage 
>class for function ‘calc_lwrk1’
>build/src/Lib/interpolate/dfitpackmodule.c:2540: error: invalid storage 
>class for function ‘calc_lwrk2’
>build/src/Lib/interpolate/dfitpackmodule.c: In function 
>‘f2py_rout_dfitpack_surfit_lsq’:
>build/src/Lib/interpolate/dfitpackmodule.c:2976: error: invalid storage 
>class for function ‘calc_lwrk1’
>build/src/Lib/interpolate/dfitpackmodule.c:2988: error: invalid storage 
>class for function ‘calc_lwrk2’
>build/src/Lib/interpolate/dfitpackmodule.c: In function 
>‘f2py_rout_dfitpack_surfit_smth’:
>build/src/Lib/interpolate/dfitpackmodule.c:2528: error: invalid storage 
>class for function ‘calc_lwrk1’
>build/src/Lib/interpolate/dfitpackmodule.c:2540: error: invalid storage 
>class for function ‘calc_lwrk2’
>build/src/Lib/interpolate/dfitpackmodule.c: In function 
>‘f2py_rout_dfitpack_surfit_lsq’:
>build/src/Lib/interpolate/dfitpackmodule.c:2976: error: invalid storage 
>class for function ‘calc_lwrk1’
>build/src/Lib/interpolate/dfitpackmodule.c:2988: error: invalid storage 
>class for function ‘calc_lwrk2’
>error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -O2 
>-march=i586 -mtune=i686 -fmessage-length=0 -Wall -D_FORTIFY_SOURCE=2 -g 
>-fPIC -Ibuild/src -I/usr/include/python2.4 -c 
>build/src/Lib/interpolate/dfitpackmodule.c -o 
>build/temp.linux-i686-2.4/build/src/Lib/interpolate/dfitpackmodule.o" 
>failed with exit status 1
>#######################################
>which I see was also posted in the past, but I cannot find the cure.
>
>I tried the cvs version:
>cvs -d :pserver:anonymous at scipy.org:/home/cvsroot login
>cvs -d :pserver:anonymous at scipy.org:/home/cvsroot checkout scipy
>
>but I cannot connect..
>
>(note that I installed f2py from the cvs version:
>cvs -d :pserver:anonymous at cens.ioc.ee:/home/cvs login
>cvs -z6 -d :pserver:anonymous at cens.ioc.ee:/home/cvs checkout f2py2e
>cd f2py2e
>make install)
>
>So my question now is: HOW can I finally install scipy!!!
>(I have a Dell D600 with SuSe10.0, python2.4)
>
>Thanks for your help,
>
>Eric
>
>_______________________________________________
>SciPy-user mailing list
>SciPy-user at scipy.net
>http://www.scipy.net/mailman/listinfo/scipy-user
>  
The cvs version is obsolete.

Please use

svn co http://svn.scipy.org/svn/scipy_core/trunk core
svn co http://svn.scipy.org/svn/scipy/trunk scipy

to get the latest version of scipy.

Nils
 



More information about the SciPy-user mailing list