[SciPy-user] problems installing f2py extensions in scipy_core

Chris Fonnesbeck fonnesbeck at gmail.com
Tue Nov 29 09:55:57 CST 2005


I am running into a new problem building a scipy_core based module
that includes f2py extrensions. When I build the project using "python
setup.py build", the build proceeds without error (including the f2py
extensions). But then when I try to install with "sudo python setup.py
install", it fails:

compiling C sources
gcc options: '-fno-strict-aliasing -Wno-long-double -no-cpp-precomp
-mno-fused-madd -fPIC -fno-common -dynamic -DNDEBUG -g -O3 -Wall
-Wstrict-prototypes'
compile options: '-Ibuild/src
-I/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/base/include
-I/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4
-c'
gcc: build/src/PyMC/flibmodule.c
compiling Fortran sources
g77(f77) options: '-Wall -fno-second-underscore -fPIC -O3
-funroll-loops -mcpu=7450 -mtune=7450'
error: PyMC/flib.f: Invalid argument

Curiously, it tries to rebuild the f2py extensions, even though they
have already been built and have not changed. This  is where it fails.
I am not doing anything different than usual, except that I am using a
recent SVN build of scipy_core.

Thanks,
C.

--
Chris Fonnesbeck
Atlanta, GA



More information about the SciPy-user mailing list