[SciPy-user] Release of SciPy Core 0.4 (Beta)

Travis Oliphant oliphant at ee.byu.edu
Mon Oct 3 22:49:36 CDT 2005


Steven H. Rogers wrote:

> "python setup.py install" for scipy_core 0.4.1 fails to build with:
>
> error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O3 
> -Wall -Wstrict-prototypes -fPIC -DNO_ATLAS_INFO=1 -Iscipy/base/include 
> -Ibuild/src/scipy/base
> -Iscipy/base/src -I/usr/local/include/python2.4 -c 
> scipy/corelib/blasdot/_dotblas.c -o 
> build/temp.linux-i686-2.4/scipy/corelib/blasdot/_dotblas.o" failed 
> with exit status 1


Hmm.  This is definitely a blas-related problem.    What other errors do 
you see.

A quick fix is to uncomment the blas_info=0 (line 15 of 
scipy/corelib/setup.py) and rerun setup (this will not try to build 
_dotblas.c

I'd like to track down what the real problem is though.

Do you see any output below
blas_opt_info: 

when you run setup.py

For example,  my system shows.

blas_opt_info:
atlas_blas_threads_info:
Setting PTATLAS=ATLAS
  NOT AVAILABLE

atlas_blas_info:
  FOUND:
    libraries = ['f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/lib/atlas']
    language = c
    include_dirs = ['/usr/include/atlas']

These include_dirs are needed to pick up cblas.h
 
-Travis







More information about the SciPy-user mailing list