[SciPy-user] Problem while importing linalg: undefined symbol: s_wsfe

Alexander Borghgraef alexander.borghgraef.rma at gmail.com
Tue Oct 11 04:10:39 CDT 2005


Hi all,

So far I thought I had a working scipy installation, until I tried out
"import linalg". I then
got the following error message:
>>> import linalg
Traceback (most recent call last):
File "<stdin>", line 1, in ?
File
"/homes/morlet/aborghgr/local/lib/python2.3/site-packages/scipy/linalg/__init__.py",
line 8, in ?
from basic import *
File
"/homes/morlet/aborghgr/local/lib/python2.3/site-packages/scipy/linalg/basic.py",
line 12, in ?
from lapack import get_lapack_funcs
File
"/homes/morlet/aborghgr/local/lib/python2.3/site-packages/scipy/linalg/lapack.py",
line 15, in ?
import flapack
ImportError:
/homes/morlet/aborghgr/local/lib/python2.3/site-packages/scipy/linalg/flapack.so:
undefined symbol: s_wsfe

 I googled for this, and I found that this error could appear when you're
building scipy with a non-gcc compiler
whereas lapack has been compiled with g77. Which is strange, since
everything I compile here uses gcc.
I installed scipy 0.3.2, compiled the ATLAS libs from source, and use a
local install of Numeric 24.0. I use
a Fedora core 3 OS, with python 2.3 and gcc 3.4.4. Any ideas?


--
Alex Borghgraef
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.scipy.net/pipermail/scipy-user/attachments/20051011/6b378a74/attachment.htm


More information about the SciPy-user mailing list