[SciPy-user] ubuntu gcc-4.0 vs. weave

Stefan van der Walt stefan at sun.ac.za
Sat Oct 15 04:01:59 CDT 2005


Hi Ryan

On Sat, Oct 15, 2005 at 04:22:08AM -0400, Ryan Krauss wrote:

> the blitz++  package (1.0.....) from the ubuntu package manager.  It
> put a lot of stuff in /usr/include/blitz.  I did not see a configure
> file.  I tried copying the blitz folder as Robert mentioned, but got
> the same message.  I even tried going into /usr/bin and modifying the
> gcc and g++ symbolic links to point to version 3.4.  This actually
> lead to a successful compile, but using the code caused some sort of
> IPP error from a python 2.4 thread.

The Blitz package that comes with Ubuntu (Breezy) is named blitz++
(1:0.8-4).  Version 0.8 of Blitz++ does not compile with g++4.  You
will have to get the 0.9 sources from their homepage.

I don't know if this will actually solve your problem, though.

Regards
Stéfan



More information about the SciPy-user mailing list