[SciPy-user] fftw, scipy ("old") install

Pearu Peterson pearu at scipy.org
Mon Oct 17 05:29:55 CDT 2005



On Mon, 17 Oct 2005, Arnd Baecker wrote:

>> The old scipy.fftpack supports only fftw2. I have a patch for fftw3
>> somewhere. I'll apply it as soon as I'll get a chance to work on fftpack.
>
> I thought it should work - at least that's how I understood
> your message
>  http://aspn.activestate.com/ASPN/Mail/Message/scipy-user/2811157
>
> So I went for
>  svn co http://svn.scipy.org/svn/scipy/trunk scipy
>  cd scipy
>  svn co http://svn.scipy.org/svn/scipy_core/trunk/ scipy_core
>
> which gives:
>  In [1]: import scipy
>  In [2]: scipy.__version__
>  Out[2]: '0.3.3_303.4573'
>
> Was this the wrong branch etc.?

Oops, indeed, the patch for fftw3 is already applied. But I haven't 
tested it yet. Looking at system_info.py, get_info('fftw') still looks for 
only fftw2 libraries. So, fftw3 support needs to be finished.

Pearu



More information about the SciPy-user mailing list