[SciPy-user] More installation troubles

Pearu Peterson pearu at scipy.org
Thu Sep 8 07:37:17 CDT 2005



On Thu, 8 Sep 2005, Alexander Borghgraef wrote:

> On 9/8/05, Pearu Peterson <pearu at scipy.org> wrote:
>>
>>
>>
>> On Thu, 8 Sep 2005, Alexander Borghgraef wrote:
>>
>> <snip>
>>> Yep. Removing numarray solved that problem. Now I'm back to the include
>>> problem described in my other post.
>>
>> Try
>>
>> python setup.py build_ext -I/homes/morlet/aborghgr/local/include/python2.3
>> build
>>
>
> Then I get the following errors:
>
> running build_ext
<snip>
> TypeError: Extension "scipy.xxx.spam" sources contains unresolved items
> (call build_src before build_ext).

Ok, but did you try

python setup.py build_src build_ext -I/homes/morlet/aborghgr/local/include/python2.3 build

as suggested in error message?

> I also tried
>
> python setup.py config --I/homes/morlet/aborghgr/local/include/python2.3
>
> and then running build, but that didn't do the trick either. I find this
> very weird: I set the PYTHONINCLUDE variable correctly,
> tried the config options, and still it uses the wrong compile options.

scipy_distutils does not use PYTHONINCLUDE or similar environment 
variables because we have `build_ext -I...`.

Pearu



More information about the SciPy-user mailing list