[SciPy-user] Installation on dual opteron ...

Fernando Perez Fernando.Perez at colorado.edu
Wed Sep 28 03:32:12 CDT 2005


Arnd Baecker wrote:
> On Tue, 27 Sep 2005, Stephen Walton wrote:
> 
> 
>>I can't help with the X11 link problem, I'm afraid, as I
>>don't see it on my i386 systems.
> 
> 
> Googling for  "ld: skipping incompatible /usr/X11R6/lib/libX11.so"
> gives quite a few hits.
> It looks like a 64Bit vs. 32 Bit thing.
> 
> And the solution is to put the following into
> scipy_core/scipy_distutils/site.cfg
> 
> [x11]
> library_dirs = /usr/X11R6/lib64
> include_dirs = /usr/X11R6/include
> 
> Then scipy builds and installs fine, but ...
> 
> In [1]: from scipy import *
> In [2]: x=arange(10.0)
> In [3]: xplt.plg(x)

Do you get this error in non-*plt code?  If so, we should worry about it, but 
if it's only being triggered by *plt code, I'm not sure it warrants spending 
preciously scarce resources, giving that in the new scipy, *plt are going to 
disappear.  There is pretty much consensus that matplotlib will take care of 
plotting and scipy will drop the old, unmaintained *plt modules.

Cheers,

f



More information about the SciPy-user mailing list