[SciPy-user] build error on itanium2

Benjamin Rutt rutt at bmi.osu.edu
Wed Sep 28 15:25:20 CDT 2005


I'm trying to build scipy from source; I've installed f2py, lapack and
blas first, and set BLAS and LAPACK.  I seem to be getting the
following error, on Itanium2.  Reading play/unix/README.fpu revealed
some discussion; should I be enabling FPU_IGNORE?  And if so, how?

Or, could I try not building xplt somehow?

Thank you.

gcc: Lib/xplt/src/play/unix/fpuset.c
Lib/xplt/src/play/unix/fpuset.c:304:2: #error <read play/unix/README.fpu for help>
Lib/xplt/src/play/unix/fpuset.c:304:2: #error <read play/unix/README.fpu for he
lp>
error: Command "gcc -pthread -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstric
t-prototypes -fPIC -Ibuild/temp.linux-ia64-2.4/config_pygist -ILib/xplt/src/gis
t -ILib/xplt/src/play -ILib/xplt/src/play/unix -I/usr/X11R6/include -I/usr/X11R
6/include -I/home/ac/rutt/.upak/installed/python-2.4/include/python2.4 -c Lib/x
plt/src/play/unix/fpuset.c -o build/temp.linux-ia64-2.4/Lib/xplt/src/play/unix/
fpuset.o -DGISTPATH="\"/home/ac/rutt/.upak/installed/python-2.4/lib/python2.4/s
ite-packages/scipy/xplt/gistdata\""" failed with exit status 1



More information about the SciPy-user mailing list