[SciPy-user] 3d plotting question

Christian Kristukat ckkart at hoc.net
Thu Sep 29 13:36:15 CDT 2005


Hi Prabhu,
I'll switch to the mayavi mailing list, ok?

Prabhu Ramachandran wrote:
>>>>>>"Christian" == Christian Kristukat <ckkart at hoc.net> writes:
> 
> 
>     >> Terrific!  VTK-4.4 is worth upgrading to if possible.  In any
>     >> case, I forgot that you can also run all the tests in
>     >> tvtk/tests to make sure the core functionality works.  I do the
>     >> following:
> 
>     Christian> I upgraded to 4.4.2 and now simple.py is no longer
>     Christian> working. Is that a TK issue?
> [...]
> 
> Did you rebuild TVTK after upgrading to 4.4.2?  If you did not, then
> remove the tvtk_classes.zip file and rebuild TVTK like so:

Yes, I've seen the warning message and rebuilt tvtk. After that, I got the error
about the missing BoxWidget.

> 
>     >> If you are willing to do a little bit of surgery, just replace
>     >> that file (wxVTKRenderWindowInteractor.py), with the latest
>     >> from here:
>     >>
>     >> http://public.kitware.com/cgi-bin/viewcvs.cgi/Wrapping/Python/vtk/wx/wxVTKRenderWindowInteractor.py?rev=1.17&view=log
> 
>     Christian> That did not work neither. He's complaining about
>     Christian> different VTK versions.
> 
> Sorry, who is complaining about different versions?

Well, I can't reproduce this now as I already upgraded to vtk 4.4.2 but when
starting the ivtk example there was a message saying, if I remember right, that
there is a version mismatch between some image lib (libpng?) of the system and
that with which VTK was compiled...? Something like that.

> 
> Thanks for the patient testing.

No problem, I'm just curious about the results.

Regards, Christian



More information about the SciPy-user mailing list