[SciPy-user] Release of SciPy Core 0.4 (Beta)

Brian Granger bgranger at scu.edu
Fri Sep 30 13:36:18 CDT 2005


Which version of gccc are you using?  As I understand it, g77 3.4 is not compatible with gcc 4.0 (the default on OS X).  Switching to gcc 3.4 might help:

gcc_select 3.3


I will soon try scipy_core on Tiger with Python 2.4.1.

Brian





Brian Granger, Ph.D.
Assistant Professor of Physics
Santa Clara University
bgranger at scu.edu
Phone: 408-551-1891
Fax: 408-554-6965
>>> managan at llnl.gov 09/30/05 11:21 AM >>>
OK, I am giving this a go.

I seem to be not setting a flag about some math functions availability.

Here are the details (aorry about the length of it but I snipped a lot!):

OSX 10.3.9, Python 2.4.1

Installed g77v3.4-bin.tar.gz from http://hpc.sourceforge.net/ as 
described into /usr/local/...
Installed fftw-3.0.1-fma.tar.gz from 
http://www.fftw.org/download.html into ~/Documents/local/... where I 
have other libraries I have installed.

Got scipy_core-0.4.1.tar.gz from 
http://sourceforge.net/project/showfiles.php?group_id=1369&package_id=6222, 
wanted to try out the new replacement for Numeric

tar -zxvf scipy_core-0.4.1.tar.gz
cd scipy_core-0.4.1
python setup.py build
Assuming default configuration 
(scipy/distutils/command/{setup_command,setup}.py was not found)
Appending scipy.distutils.command configuration to scipy.distutils
Assuming default configuration 
(scipy/distutils/fcompiler/{setup_fcompiler,setup}.py was not found)
...
Appending scipy.base configuration to scipy
blas_opt_info:
   FOUND:
     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
     define_macros = [('NO_ATLAS_INFO', 3)]
     extra_compile_args = ['-faltivec', 
'-I/System/Library/Frameworks/vecLib.framework/Headers']

lapack_opt_info:
   FOUND:
     extra_link_args = ['-Wl,-framework', '-Wl,Accelerate']
     define_macros = [('NO_ATLAS_INFO', 3)]
     extra_compile_args = ['-faltivec']

Appending scipy.lib configuration to scipy
Assuming default configuration 
(scipy/fftpack/{setup_fftpack,setup}.py was not found)

...
scipy_core version 0.4.1
running build
running config_fc
running build_src
building extension "scipy.base.multiarray" sources
creating build
creating build/src
creating build/src/scipy
creating build/src/scipy/base
Generating build/src/scipy/base/config.h
customize NAGFCompiler
customize AbsoftFCompiler
customize IbmFCompiler
Could not locate executable f77
customize GnuFCompiler
customize GnuFCompiler
...
compiling C sources
gcc options: '-fno-strict-aliasing -Wno-long-double -no-cpp-precomp 
-mno-fused-madd -fno-common -dynamic
-DNDEBUG -g -O3 -Wall -Wstrict-prototypes'
creating build/temp.darwin-7.9.0-Power_Macintosh-2.4/build
creating build/temp.darwin-7.9.0-Power_Macintosh-2.4/build/src
creating build/temp.darwin-7.9.0-Power_Macintosh-2.4/build/src/scipy
creating build/temp.darwin-7.9.0-Power_Macintosh-2.4/build/src/scipy/base
creating build/temp.darwin-7.9.0-Power_Macintosh-2.4/build/src/scipy/base/src
compile options: '-Ibuild/src/scipy/base/src -Iscipy/base/include 
-Ibuild/src/scipy/base -Iscipy/base/src
  -I/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4 -c'
gcc: build/src/scipy/base/src/umathmodule.c
In file included from build/src/scipy/base/src/umathmodule.c:8:
scipy/base/include/scipy/arrayobject.h:84: warning: redefinition of `ushort'
/usr/include/sys/types.h:82: warning: `ushort' previously declared here
scipy/base/include/scipy/arrayobject.h:85: warning: redefinition of `uint'
/usr/include/sys/types.h:83: warning: `uint' previously declared here
build/src/scipy/base/src/umathmodule.c: In function `nc_floor_quotl':
build/src/scipy/base/src/umathmodule.c:1257: warning: implicit 
declaration of function `floorl'
build/src/scipy/base/src/umathmodule.c: In function `nc_sqrtl':
build/src/scipy/base/src/umathmodule.c:1269: warning: implicit 
declaration of function `sqrtl'
...
build/src/scipy/base/__umath_generated.c:171: error: initializer 
element is not constant
build/src/scipy/base/__umath_generated.c:171: error: (near 
initialization for `arccosh_data[2]')
error: Command "gcc -fno-strict-aliasing -Wno-long-double 
-no-cpp-precomp -mno-fused-madd -fno-common -dy
namic -DNDEBUG -g -O3 -Wall -Wstrict-prototypes 
-Ibuild/src/scipy/base/src -Iscipy/base/include -Ibuild/s
rc/scipy/base -Iscipy/base/src 
-I/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4 
-c b
uild/src/scipy/base/src/umathmodule.c -o 
build/temp.darwin-7.9.0-Power_Macintosh-2.4/build/src/scipy/base
/src/umathmodule.o" failed with exit status 1


At 12:59 AM -0600 9/30/05, Travis Oliphant wrote:
>This is to announce the release of SciPy Core 0.4.X (beta)
>
>It is available at sourceforge which you can access by going to
>
>http://numeric.scipy.org
>
>Thanks to all who helped me with this release, especially
>
>Robert Kern
>Pearu Peterson
>
>Now, let's start getting this stable....
>
>-Travis Oliphant
>
>
>
>_______________________________________________
>SciPy-user mailing list
>SciPy-user at scipy.net
>http://www.scipy.net/mailman/listinfo/scipy-user


-- 
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
Rob Managan               email managan at llnl.gov
LLNL                      phone: 925-423-0903
P.O. Box 808, L-095       FAX:   925-422-3389
Livermore, CA  94551-0808

_______________________________________________
SciPy-user mailing list
SciPy-user at scipy.net
http://www.scipy.net/mailman/listinfo/scipy-user


This message scanned for viruses and SPAM at SCU (MGW2)



More information about the SciPy-user mailing list