[SciPy-user] ask help for scipy install

Ryan Krauss ryanlists at gmail.com
Sun Apr 2 12:55:47 CDT 2006


I run scipy in Ubuntu Breezy, so it definitely works.  But I installed
from source, so I can't tell you what might be wrong with the package.
 Installing from source in Ubuntu isn't too painful since Atlas, Blas,
Lapack and all that are available as packages (that I know do work). 
If you can't resolve your issue with the package install, let me know
if you want help installing from source.

Ryan

On 4/2/06, imcs ee <imcsee at gmail.com> wrote:
> in ubuntu5.10
> i install scipy with apt-get install scipy
>
> and run the unittest
>
> from scipy import *
> test(10)
>
> it shows the result as below.  is here any guide to solve it? thanks in
> advance
>
>
> ======================================================================
> FAIL: check_expon
> (scipy.stats.morestats.test_morestats.test_anderson)
> ----------------------------------------------------------------------
>  Traceback (most recent call last):
>   File
> "/usr/lib/python2.4/site-packages/scipy/stats/tests/test_morestats.py",
> line 55, in check_expon
>     assert_array_less(A, crit[-2:])
>   File
> "/usr/lib/python2.4/site-packages/scipy_test/testing.py",
> line 708, in
> assert_array_less
>     assert cond,\
> AssertionError:
> Arrays are not less-ordered (mismatch 50.0%):
>         Array 1: 1.65613125073
>         Array 2: [ 1.587               1.9339999999999999]
>
>
> ----------------------------------------------------------------------
> Ran 986 tests in 102.422s
>
> FAILED (failures=1)
> Out[3]: <unittest.TextTestRunner object at 0xb45a580c>
>
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user
>
>
>



More information about the SciPy-user mailing list