[SciPy-user] No module named _umfpack

Robert Cimrman cimrman3 at ntc.zcu.cz
Tue Apr 18 10:41:01 CDT 2006


Darren Dale wrote:
> On Tuesday 18 April 2006 08:35, Robert Cimrman wrote:
> 
>>Darren Dale wrote:
>>
>>>For any gentoo users out there, a umfpack ebuild is available here:
>>>http://gentooscience.org/browser/overlay/sci-libs/umfpack.
>>>
>>>I was able to build scipy with umfpack support on an 64bit Athlon machine
>>>using this ebuild, which provides version 4.6 with support to build
>>>shared libraries. No changes to site.cfg were necessary.
>>>
>>>scipy.test() and scipy.linsolve.umfpack.test() were both successful.
>>
>>great news! I will try it immediately :)
> 
> 
> Oh, let me make clear, the ebuild provides support to build shared libraries, 
> not the umfpack-4.6 package itself. More information here: 
> http://bugs.gentoo.org/show_bug.cgi?id=40255

well, it works well for me, moreover I got about 30% speed-up w.r.t the 
manually built version 4.4 for a simple problem I had at hand.

Conclusion: the wrappers seem to work also with the version 4.6; still 
there might be some extra functionality in 4.6 worth exposing, I will 
check it out when time permits.

r.



More information about the SciPy-user mailing list