[SciPy-user] import linsolve.umfpack failure

Jon Willits willits at wisc.edu
Mon Aug 21 14:57:11 CDT 2006


I have installed scipy on an Intel Mac (running python 2.4.3) using  
the ScipySuperpack-Intel-10.4.tar. Everything seems to have installed  
ok, except that when I import scipy, I get this message:

import linsolve.umfpack -> failed: Failure linking new module: / 
Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site- 
packages/scipy/sparse/sparsetools.so: Library not loaded: /usr/local/ 
lib/libgfortran.1.dylib
   Referenced from: /Library/Frameworks/Python.framework/Versions/2.4/ 
lib/python2.4/site-packages/scipy/sparse/sparsetools.so
   Reason: image not found

I noticed an earlier posting about this, with a message that said  
something like "oops, bad linking" but without any advice on how to  
fix it. My programs run fine (they do not rely on the sparse  
libraries), but always produce that error message, which will not be  
good for all kinds of reasons. Is there a way to fix this, or at a  
minimum, to suppress this error message?

Thanks,
Jon Willits
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20060821/deca3ec2/attachment.html 


More information about the SciPy-user mailing list