[SciPy-user] amd64 specific error in fitpack spline interpolation

Darren Dale dd55 at cornell.edu
Wed Aug 30 07:24:46 CDT 2006


On Wednesday 30 August 2006 07:22, George Nurser wrote:
> On 30 Aug 2006, at 11:00, Angus McMorland wrote:
> > Hi all,
> >
> > I posted about this problem a few months ago, but we didn't get very
> > far, but the annoyance level of the problem is enough now for me to
> > have
> > another go.
> >
> > I'm trying to run the spline example from the cookbook (my exact code,
> > called spl.py, is inlined below). On an ix86 computer this works fine,
> > and returns the expected graphs, but on an amd64 machine I get the
> > error
> > below. Both computers are running debian etch, with recent svn
> > numpy and
> > scipy.
> >
> > TypeError: array cannot be safely cast to required type
> >
> >> /usr/lib/python2.4/site-packages/scipy/interpolate/fitpack.py(217)
> >> splprep()
> >
> >     216
> > t,c,o=_fitpack._parcur(ravel(transpose(x)),w,u,ub,ue,k,task,ipar,s,t,
> > --> 217                              nest,wrk,iwrk,per)
> >     218     _parcur_cache['u']=o['u']
> >
> > I believe the error is generated by the _parcur call -> once in pdb,
> > calling it again re-raises the same error.
> >
> > ipdb>_fitpack._parcur(ravel(transpose(x)),w,u,ub,ue,k,task,ipar,s,t,
> > nest,wrk,iwrk,per)
>
> Same problem on our Opterons.
> numpy v 2631
> scipy  v 1614
> built & linked to acml

I also see it on an Athlon, with numpy 1.0b5.dev3094, scipy 0.5.1.dev2184, 
linked to atlas 3.7.11.


More information about the SciPy-user mailing list