[SciPy-user] Could you help me?

Rich Shepard rshepard at appl-ecosys.com
Wed Aug 30 09:31:35 CDT 2006


On Wed, 30 Aug 2006, Xiang Peng wrote:

> It's fine with numpy. But somehow I can't get scipy into working properly.
> When I tried to import scipy, it always says: RuntimeError: module
> compiled against version 1000000 of C-API but this version of numpy is
> 1000002.

Xiang,

   You need the latest SVN builds for both of them. On the SciPy web site's
download page you'll find the syntax to check out each. Make a directory for
numpy/ and one for scipy/, cd to each in turn and run 'svn co ...' to get
the trunk for each. If these directories already exist, 'rm -rf *' to get a
clean install.

   Then, as root in the numpy/ directory re-run 'python setup.py install.'

   Now, before you do anything with SciPy, follow the links and install BLAS,
LAPACK, and ATLAS. Once those are successfully built in subdirectories
within scipy/, then run 'python setup.py install' on that code.

HTH,

Rich

-- 
Richard B. Shepard, Ph.D.               |    The Environmental Permitting
Applied Ecosystem Services, Inc.(TM)    |            Accelerator
<http://www.appl-ecosys.com>     Voice: 503-667-4517      Fax: 503-667-8863


More information about the SciPy-user mailing list