[SciPy-user] Problem with Windows Scipy 0.5

David Linke davidlinke at tiscali.de
Thu Aug 31 14:22:52 CDT 2006


Tony Triolo wrote:
> I've been trying to use Scipy 0.5 with Python 2.4 for Windows and can't
> seem to get it to play nicely with any version of Numpy.  Here is what I
> have tried along with the result:
> 
(...)

> RuntimeError: module compiled against version 1000000 of C-API but this
> version of numpy is 1000002
> 
> **********************************
> 
> The installer used for Scipy was : scipy-0.5.0.win32-py2.4.exe
> and the installer for Numpy was : numpy-1.0b4.win32-py2.4.exe

Hi Tony!

You have to use a (C-API) compatible Numpy version which should be 
numpy-1.0b1.win32-py2.4.exe for your scipy download. ...but it seems 
like this is no longer available on SF for download. If you don't want 
to compile yourself you may also give http://code.enthought.com/enthon/ 
a try.

The download page on the wiki is not pointing out this C-API 
compatibility issue clearly. To avoid confusion it would be good to add 
the numpy version which was used for compiling scipy into the name of 
the binary in the future. E.g.
scipy-0.5.0-numpy1.0.1b1-win32-py2.4.exe

Regards,
David


More information about the SciPy-user mailing list