[SciPy-user] Scipy Superpack (was Re: pajer at iname.com has sent you a file.)

Robert Kern robert.kern at gmail.com
Fri Dec 1 19:24:20 CST 2006


R. Padraic Springuel wrote:
> So, I downloaded and installed those files, but am still getting the 
> same error.
> 
> Also, I installed the Superpack on my Mac system and can't seem to 
> import either scipy or matplotlib.  I get the following errors:
> 
> Traceback (most recent call last):
>    File "<stdin>", line 1, in ?
>    File 
> "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/pylab.py", 
> line 1, in ?
>      from matplotlib.pylab import *
> ImportError: No module named matplotlib.pylab

That would indeed be a problem. Chris might not be reading this thread, so
hopefully my changing the subject line will grab his attention.

> Traceback (most recent call last):
>    File "<stdin>", line 1, in ?
> NameError: name 'python' is not defined
>  >>> from scipy import *
> Traceback (most recent call last):
>    File "<stdin>", line 1, in ?
>    File 
> "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/__init__.py", 
> line 8, in ?
>      from basic import *
>    File 
> "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/basic.py", 
> line 17, in ?
>      from lapack import get_lapack_funcs
>    File 
> "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/lapack.py", 
> line 17, in ?
>      from scipy.linalg import flapack
> ImportError: Failure linking new module: 
> /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/flapack.so: 
> Library not loaded: /usr/local/lib/libgfortran.1.dylib
>    Referenced from: 
> /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/flapack.so
>    Reason: image not found
> 
> What does all that mean?  I thought the Superpack installs were supposed 
> to work right out of the box?

No, as the website says:

"""To avoid compatibility issues, you should install the gFortran compiler and
the GCC 4.0 compiler tools (both also included) before installing these packages."""

Install the gfortran compiler given in the tarball. It contains the runtime
libraries that all of the scipy fortran wrappers compiled against.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
 that is made terrible by our own mad attempt to interpret it as though it had
 an underlying truth."
  -- Umberto Eco


More information about the SciPy-user mailing list