[SciPy-user] additional superpak problems

belinda thom bthom at cs.hmc.edu
Sat Dec 30 13:51:08 CST 2006


Again, regarding SciPy Superpack for Python 2.4 (Power PC), PyMC-1.1- 
py2.4-macosx10.4.mpkg and scipy-0.5.2.dev2095-py2.4-macosx10.4.mpkg  
are problematic.

For example, after installing all the superpack packages, behavior  
like the following results. A similar error occurs when doing  
spicy.test(). Only numpy's test worked w/no errors.

It seems to me that superpaks with these kind of problems should not  
be listed as what to download at the Scipy download site.

22 % python
Python 2.4.4 (#1, Oct 18 2006, 10:34:39)
[GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
history mechanism set up
 >>> import PyMC
Matplotlib module not detected ... plotting disabled.
Matplotlib module not detected ... plotting disabled.
Traceback (most recent call last):
   File "<stdin>", line 1, in ?
   File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/PyMC/__init__.py", line 19, in ?
     exec "from %s import *" % mod
   File "<string>", line 1, in ?
   File "/Library/Frameworks/Python.framework/Versions/2.4/lib/ 
python2.4/site-packages/PyMC/MCMC.py", line 37, in ?
     from flib import categor as _categorical
ImportError: Failure linking new module: /Library/Frameworks/ 
Python.framework/Versions/2.4/lib/python2.4/site-packages/PyMC/ 
flib.so: Library not loaded: /usr/local/lib/libg2c.0.dylib
   Referenced from: /Library/Frameworks/Python.framework/Versions/2.4/ 
lib/python2.4/site-packages/PyMC/flib.so
   Reason: image not found




More information about the SciPy-user mailing list