[SciPy-user] additional superpak problems

Vincent Nijs v-nijs at kellogg.northwestern.edu
Sat Dec 30 14:19:05 CST 2006


--b,

I had the same problem with ipython on OS X 10.4. I installed it from
http://ipython.scipy.org/moin/Download and then everything worked fine,
including 'import PyMC'.

I do get the warnings below from scipy.test(). However, I have not had any
problems running scipy so I assume these are not problematic for speed or
functionality.

Best,

Vincent

Warning: FAILURE importing tests for <module
'scipy.linsolve.umfpack.umfpack' from '...y/linsolve/umfpack/umfpack.pyc'>
/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-package
s/scipy/linsolve/umfpack/tests/test_umfpack.py:17: AttributeError: 'module'
object has no attribute 'umfpack' (in ?)


Warning: FAILURE importing tests for <module 'scipy.linsolve.umfpack' from
'.../linsolve/umfpack/__init__.pyc'>
/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-package
s/scipy/linsolve/umfpack/tests/test_umfpack.py:17: AttributeError: 'module'
object has no attribute 'umfpack' (in ?)

****************************************************************
WARNING: clapack module is empty
-----------
See scipy/INSTALL.txt for troubleshooting.
Notes:
* If atlas library is not found by numpy/distutils/system_info.py,
  then scipy uses flapack instead of clapack.
****************************************************************

....................................../Library/Frameworks/Python.framework/V
ersions/2.4/lib/python2.4/site-packages/scipy/interpolate/fitpack2.py:457:
UserWarning: 
The coefficients of the spline returned have been computed as the
minimal norm least-squares solution of a (numerically) rank deficient
system (deficiency=7). If deficiency is large, the results may be
inaccurate. Deficiency may strongly depend on the value of eps.
  warnings.warn(message)
............................................................................
........Ties preclude use of exact statistic.
..Ties preclude use of exact statistic.



On 12/30/06 1:51 PM, "belinda thom" <bthom at cs.hmc.edu> wrote:

> Again, regarding SciPy Superpack for Python 2.4 (Power PC), PyMC-1.1-
> py2.4-macosx10.4.mpkg and scipy-0.5.2.dev2095-py2.4-macosx10.4.mpkg
> are problematic.
> 
> For example, after installing all the superpack packages, behavior
> like the following results. A similar error occurs when doing
> spicy.test(). Only numpy's test worked w/no errors.
> 
> It seems to me that superpaks with these kind of problems should not
> be listed as what to download at the Scipy download site.
> 
> 22 % python
> Python 2.4.4 (#1, Oct 18 2006, 10:34:39)
> [GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
> history mechanism set up
>>>> import PyMC
> Matplotlib module not detected ... plotting disabled.
> Matplotlib module not detected ... plotting disabled.
> Traceback (most recent call last):
>    File "<stdin>", line 1, in ?
>    File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
> python2.4/site-packages/PyMC/__init__.py", line 19, in ?
>      exec "from %s import *" % mod
>    File "<string>", line 1, in ?
>    File "/Library/Frameworks/Python.framework/Versions/2.4/lib/
> python2.4/site-packages/PyMC/MCMC.py", line 37, in ?
>      from flib import categor as _categorical
> ImportError: Failure linking new module: /Library/Frameworks/
> Python.framework/Versions/2.4/lib/python2.4/site-packages/PyMC/
> flib.so: Library not loaded: /usr/local/lib/libg2c.0.dylib
>    Referenced from: /Library/Frameworks/Python.framework/Versions/2.4/
> lib/python2.4/site-packages/PyMC/flib.so
>    Reason: image not found
> 
> 
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user
> 




More information about the SciPy-user mailing list