[SciPy-user] Replacing Numeric With NumPy

David M. Cooke cookedm at physics.mcmaster.ca
Wed Feb 8 21:40:33 CST 2006


Rich Shepard <rshepard at appl-ecosys.com> writes:

>    Last evening I downloaded numpy-0.9.4 and scipy-0.4.4. I have an earlier
> version of Numeric in /usr/lib/python2.4/site-packages/Numeric/. Should I
> remove all references to Numeric before installing NumPy?

As Pearu said, there's no need. You may wish to make sure you're using
Numeric 24.2, though; with that version, passing Numeric arrays to
numpy functions and vice versa a very low-cost operation, so you could
keep a mixture of the two codes until you finish switching over.

-- 
|>|\/|<
/--------------------------------------------------------------------------\
|David M. Cooke                      http://arbutus.physics.mcmaster.ca/dmc/
|cookedm at physics.mcmaster.ca



More information about the SciPy-user mailing list