[SciPy-user] SciPy on mandriva

manouchk manouchk at gmail.com
Tue Feb 14 07:41:59 CST 2006


Le Mardi 14 Février 2006 07:08, Gerard Vermeulen a écrit :
> On Mon, 13 Feb 2006 19:41:57 -0200
>
> manouchk <manouchk at gmail.com> wrote:
> > Has anyone compiled/installed successfully SciPy 0.4.4 on mandriva 2005?
>
> I build RPMs from SVN snapshots of numpy and scipy on Mandriva-2005 and I
> don't recall any problems around the time SciPy-0.4.4 has been released.

It finally worked, after installing dependancies to create matplotlib (and 
maybe some others), I think there should be some missing dependancies in 
cooker rpm SciPy-0.4.3, maybe tk-devel, tcl-devel?
If someone is interested to recompile (or give a try etc...), anyway I put 
rpms and srpms here :
http://emmanuelfavrenicolin.free.fr/Public/Ordinateur/Mandriva/MDV2005LE/SRPMS/python-SciPy-0.4.4-0.1.102mdk.src.rpm
http://emmanuelfavrenicolin.free.fr/Public/Ordinateur/Mandriva/MDV2005LE/RPMS/python-SciPy-0.4.4-0.1.102mdk.i586.rpm

> Once you've got all dependencies installed, it is really easy.  That is:
> find all development RPMs and install atlas (which is most difficult if
> you want a really optimized atlas, Mandriva has a 'universal' atlas
> package, I believe).

I fortunatly don't need specially an optimized atlas!

Cheers,
Emmanuel (Favre-Nicolin)

> Gerard



More information about the SciPy-user mailing list