[SciPy-user] Do I need to get and install LAPACK if I have ATLAS?

skip@pobox.com skip at pobox.com
Thu Feb 23 20:29:31 CST 2006


    Robert> I'm impressed. I would think ar(1) should be fairly stable on any platform.

Me too.  I eventually got it to work.  Dunno what the problem was.  We have
Solaris 8/9/10 so we have to do our compiles and links on 8 for backward
compatibility.  I ran the ar(1) command on 10 and it worked.  I think the
core dump was on 8.

    Robert> Do you need an optimized BLAS/LAPACK, or will the reference
    Robert> implementations do?

Maybe.  I had so much time invested in ATLAS wrangling, so I kept at it.  I
now have ATLAS+LAPACK+numpy+scipy built with GCC 3.4.1 and Python 2.4.2
installed and apparently working okay on Solaris.  I added some terse
directions on the wiki at work for others who may one day trod the same
harrowing path I've been down.  Is there a public wiki where I can submit a
suitably site-independent version of these instructions?

Skip



More information about the SciPy-user mailing list