[SciPy-user] ATLAS and gcc v4.0.2

Christian Kristukat ckkart at hoc.net
Tue Feb 28 03:58:03 CST 2006


Nils Wagner wrote:
> On Tue, 28 Feb 2006 18:29:44 +0900
>   Christian Kristukat <ckkart at hoc.net> wrote:
>> Nils Wagner wrote:
>>> Hi all,
>>>
>>> Where can I find some hints w.r.t. to ATLAS and 
>>> scipy/numpy ?
>>> AFAIK the new website has no information on building 
>>> ATLAS.
>> Well, at least it provides a link to a page with install 
>> instructions:
>>
>> http://www.scipy.org/Installing_SciPy/Linux
>>
>>> Do I need version 3 of gcc ?
>>>
>>> I am on SuSE Linux 10.0 with gcc v4.0.2
>>>
>> In addition to what was already said, I noticed that its 
>> important, that the
>> gfortran compiler is used and not g77. The easiest way 
>> to achieve that, is to
>> make sure that compat-g77.rpm is not installed, but 
>> gfortran.rpm is.
>>
>> And yes, gcc4 works without problems though I can't say 
>> anything about performance.
>>
>> Eric gave instructions to compile f2py. That, however is 
>> not needed with numpy
>> as it's already included.
>>
>> Regards, Christian
>>
>> _______________________________________________
>> SciPy-user mailing list
>> SciPy-user at scipy.net
>> http://www.scipy.net/mailman/listinfo/scipy-user
> 
>   
> Hi Christian,
> 
> SuSE 10.0 comes with gcc-fortran
> 
> Name        : gcc-fortran                  Relocations: 

You're right. But the executable is called 'gfortran'. I mixed that up.

Christian



More information about the SciPy-user mailing list