[SciPy-user] Renaming scipy_core: here we go again

Ted Horst ted.horst at earthlink.net
Wed Jan 4 02:36:34 CST 2006


My (limited) understanding is that scipy_core is primarily the 
multidimensional array class and supporting infrastructure.  It is not 
all that scientific except that linear algebra and ffts have been 
bundled with it.  So perhaps the name should be something along the 
lines of:

ndarray
multiarray
bigarray

Ted

On Jan 3, 2006, at 22:08, Gary wrote:

> Frank wrote:
>
>> Dear All,
>>
>> I vote for "scicore". Anything to make the division between scipy
>> core and numeric more clear.
>>
>>
> ... as well as the distinction between scipy core and scipy.
>
> scicore gets my vote from that list, but IMO a more application-neutral
> name would be preferable.  Of course, I don't have any suggestions.  
> Too
> bad "numeric" and "numpy" are taken.  I'll sleep on it and see if I can
> come up with a winner  :)
>
> -gary
>
>> Thanks,
>> Frank
>>
>> _______________________________________________
>> SciPy-user mailing list
>> SciPy-user at scipy.net
>> http://www.scipy.net/mailman/listinfo/scipy-user
>>
>>
>>
>
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user
>



More information about the SciPy-user mailing list