[SciPy-user] Problems compiling SciPy in Cygwin

Fernando Perez Fernando.Perez at colorado.edu
Fri Jan 6 16:19:13 CST 2006


Travis Oliphant wrote:
> Crider, Joseph A wrote:
> 
> 
>>After some more digging through documentation on Python.org and
>>experimentation, I think I may have come up with a satisfactory answer
>>for my needs at least.  I had been just using the command
>>	python setup.py build
>>to build SciPy.  Changing the command to
>>	python setup.py build --compiler=cygwin
>>resulted in an error similar to that below in the xplt module.  Since I
>>don't plan to use xplt, I placed that in the list ignore_packages in
>>setup.py and got a successful build.
>>
>>
>> 
>>
> 
> Thanks for reporting your solution.   I'm pretty sure this is with SciPy 
> 0.3.2 and Numeric as a base.
> 
> The new SciPy 0.4.X  requires NumPy as a base.  But, similar 
> instructions are probably in order there as well..

Except that xplt is off by default in scipy (it's only in the sandbox), so 
hopefully less problems will arise.

Still, the --compiler=cygwin nugget is a good one for win32 users.

Cheers,

f



More information about the SciPy-user mailing list