[SciPy-user] numpy and fcompiler

Pearu Peterson pearu at scipy.org
Fri Jan 13 13:22:31 CST 2006



On Fri, 13 Jan 2006, Eric Zollars wrote:

> I cannot get numpy-0.9.2 to build with the correct compiler.  Starting
> with a clean directory the command:
> python setup.py config_fc --fcompiler=ibm
> --f77exec=/opt/ibmcmp/xlf/8.1/bin/xlf
> --f90exec=/opt/ibmcmp/xlf/8.1/bin/xlf90 --f77flags=-qextname
> --f90flags=-qextname build
>
> still leads to the error
> warning: build_ext: fcompiler=ibm is not available.
>
> Anything I can try to figure this out?

What is the output of

   xlf

? If this does not contain xlf version information, then it is assumed
that the version info can be obtained from the listing of 
/etc/opt/ibmcmp/xlf/. See numpy/distutils/fcompiler/ibm.py for more 
information. I can fix this if you send me the output of `xlf` and confirm
that /opt/ibmcmp/xlf/8.1/etc/xlf.cfg exists (or send me the fullpath to 
xlf.cfg).

Pearu



More information about the SciPy-user mailing list