[SciPy-user] numpy and fcompiler

mfmorss@aep.com mfmorss at aep.com
Fri Jan 13 15:55:10 CST 2006


May ask what system you're running on?  I could not tell from your post.  I
have numpy running on AIX 5.2, but at present, we don't have Fortran.

Mark F. Morss
Principal Analyst, Market Risk
American Electric Power


                                                                           
             Eric Zollars                                                  
             <zollars at caltech.                                             
             edu>                                                       To 
             Sent by:                  SciPy Users List                    
             scipy-user-bounce         <scipy-user at scipy.net>              
             s at scipy.net                                                cc 
                                                                           
                                                                   Subject 
             01/13/2006 04:19          Re: [SciPy-user] numpy and          
             PM                        fcompiler                           
                                                                           
                                                                           
             Please respond to                                             
             SciPy Users List                                              
             <scipy-user at scipy                                             
                   .net>                                                   
                                                                           
                                                                           




Pearu-
             The command xlf gives compiler options, no version
information.  I have
already checked ibm.py and the xlf.cfg is where it is supposed to be:
/etc/opt/ibmcmp/xlf/8.1/xlf.cfg

Eric

Pearu Peterson wrote:
>
> On Fri, 13 Jan 2006, Eric Zollars wrote:
>
>
>>I cannot get numpy-0.9.2 to build with the correct compiler.  Starting
>>with a clean directory the command:
>>python setup.py config_fc --fcompiler=ibm
>>--f77exec=/opt/ibmcmp/xlf/8.1/bin/xlf
>>--f90exec=/opt/ibmcmp/xlf/8.1/bin/xlf90 --f77flags=-qextname
>>--f90flags=-qextname build
>>
>>still leads to the error
>>warning: build_ext: fcompiler=ibm is not available.
>>
>>Anything I can try to figure this out?
>
>
> What is the output of
>
>    xlf
>
> ? If this does not contain xlf version information, then it is assumed
> that the version info can be obtained from the listing of
> /etc/opt/ibmcmp/xlf/. See numpy/distutils/fcompiler/ibm.py for more
> information. I can fix this if you send me the output of `xlf` and
confirm
> that /opt/ibmcmp/xlf/8.1/etc/xlf.cfg exists (or send me the fullpath to
> xlf.cfg).
>
> Pearu
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user

_______________________________________________
SciPy-user mailing list
SciPy-user at scipy.net
http://www.scipy.net/mailman/listinfo/scipy-user




More information about the SciPy-user mailing list