[SciPy-user] scipy 0.4.4 problems with converters.blitz

Christian Kristukat ckkart at hoc.net
Fri Jan 27 07:04:47 CST 2006


Hi,
I've got problems getting inline code to work after having updated from 0.3.2 to
0.4.4. Automatic argument conversion with converters.blitz fails (try the
array3d.py example) with this error message:

In file included from
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/compiler.h:31,
                 from
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/blitz.h:47,
                 from
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/array-impl.h:41,
                 from
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/array.h:32,
                 from
/home/ck/.python23_compiled/sc_9824b12a96792c10b5fdb725f9caa3c414.cpp:5:
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/bzconfig.h:39:32:
blitz/gnu/bzconfig.h: No such file or directory
In file included from
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/blitz.h:47,
                 from
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/array-impl.h:41,
                 from
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/array.h:32,
                 from
/home/ck/.python23_compiled/sc_9824b12a96792c10b5fdb725f9caa3c414.cpp:5:
/usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/compiler.h:38:6: #error
In <blitz/config.h>: A working template implementation is required by Blitz++
(you may need to rerun the compiler/bzconfig script)

I've tried to install Blitz 0.9, so that at least weave can find the header file
 "gnu/bzconfig.h" but it didn't really help.

Any ideas what is wrong?

Regards, Christian



More information about the SciPy-user mailing list