[SciPy-user] scipy 0.4.4 problems with converters.blitz

David M. Cooke cookedm at physics.mcmaster.ca
Fri Jan 27 15:08:33 CST 2006


Pearu Peterson <pearu at scipy.org> writes:

> On Fri, 27 Jan 2006, Travis Oliphant wrote:
>
>>>> /home/ck/.python23_compiled/sc_9824b12a96792c10b5fdb725f9caa3c414.cpp:5:
>>>> /usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/compiler.h:38:6:
>>>> #error
>>>> In <blitz/config.h>: A working template implementation is required by Blitz++
>>>> (you may need to rerun the compiler/bzconfig script)
>>>>
>>>> I've tried to install Blitz 0.9, so that at least weave can find the header
>>>> file
>>>> "gnu/bzconfig.h" but it didn't really help.
>>>>
>>>> Any ideas what is wrong?
>>
>> Try moving the gnu/bzconfig.h file from the installation directory to
>> the weave directory
>>
>> /usr/lib/python2.3/site-packages/scipy/weave/blitz/blitz/gnu
>>
>> Then try again.
>>
>> We may be missing some files when the upgrade in blitz occurred.
>
> Indeed, scipy/Lib/weave/blitz/blitz/gnu is an empty directory in scipy 
> SVN.

Fixed. I added the bzconfig.h that I had used when I updated it last.

-- 
|>|\/|<
/--------------------------------------------------------------------------\
|David M. Cooke                      http://arbutus.physics.mcmaster.ca/dmc/
|cookedm at physics.mcmaster.ca



More information about the SciPy-user mailing list