[SciPy-user] can't import scipy.interpolate

Gary pajer at iname.com
Wed Jun 21 14:20:19 CDT 2006


Robert Kern wrote:
> Gary wrote:
>   
>>  >>> scipy.__core_version__
>> '0.8.4'
>>  >>> import scipy.interpolate
>> Fatal Python error: can't initialize module fitpack
>>
>> This application has requested the Runtime to terminate it in an unusual 
>> way.
>> Please contact the application's support team for more information.
>>     
>
> Hmm. That looks like an old build from when we were still calling numpy "scipy
> core". Probably there is a mismatch between the "scipy core" version (that's the
> version number you printed) and the scipy version (scipy.__version__).
>   
I thought that was weird, too.   I did some housecleaning over the 
weekend, and I must have screwed things up instead of cleaned things up.
> I recommend upgrading to the latest numpy and scipy.
>   
OK, so I got rid of all my build directories, and my numpy and scipy 
directories, and tried to rebuild from svn (for no particular reason, 
but I've done it easily in the past).  Numpy went fine, but scipy did 
this:  (I don't want to waste people's time on this ... if it's 
something peculiar to me, and hard to track down, I'll just go back to 
the official released binary installer.)

C:\Documents and Settings\Gary\My 
Documents\python\scipy\svn_scipy>python setup.
py config --compiler=mingw32 build --compiler=mingw32 bdist_wininst
fft_opt_info:
fftw3_info:
  libraries fftw3 not find in c:\python24\lib
  libraries fftw3 not find in C:\
  libraries fftw3 not find in c:\python24\libs
  fftw3 not found
  NOT AVAILABLE

fftw2_info:
  libraries rfftw,fftw not find in c:\python24\lib
  libraries rfftw,fftw not find in C:\
  libraries rfftw,fftw not find in c:\python24\libs
  fftw2 not found
  NOT AVAILABLE

dfftw_info:
  libraries drfftw,dfftw not find in c:\python24\lib
  libraries drfftw,dfftw not find in C:\
  libraries drfftw,dfftw not find in c:\python24\libs
  dfftw not found
  NOT AVAILABLE

djbfft_info:
  NOT AVAILABLE

  NOT AVAILABLE

blas_opt_info:
blas_mkl_info:
  libraries mkl,vml,guide not find in c:\python24\lib
  libraries mkl,vml,guide not find in C:\
  libraries mkl,vml,guide not find in c:\python24\libs
  NOT AVAILABLE

atlas_blas_threads_info:
Setting PTATLAS=ATLAS
  libraries ptf77blas,ptcblas,atlas not find in c:\MinGW\lib\atlas
  libraries ptf77blas,ptcblas,atlas not find in c:\python24\lib
  libraries ptf77blas,ptcblas,atlas not find in C:\
  libraries ptf77blas,ptcblas,atlas not find in c:\python24\libs
  NOT AVAILABLE

atlas_blas_info:
  FOUND:
    libraries = ['f77blas', 'cblas', 'atlas']
    library_dirs = ['c:\\MinGW\\lib\\atlas']
    language = c

No module named msvccompiler in numpy.distutils, trying from distutils..
Traceback (most recent call last):
  File "setup.py", line 50, in ?
    setup_package()
  File "setup.py", line 42, in setup_package
    configuration=configuration )
  File "c:\python24\Lib\site-packages\numpy\distutils\core.py", line 
140, in set
up
    config = configuration()
  File "setup.py", line 14, in configuration
    config.add_subpackage('Lib')
  File "c:\python24\Lib\site-packages\numpy\distutils\misc_util.py", 
line 740, i
n add_subpackage
    caller_level = 2)
  File "c:\python24\Lib\site-packages\numpy\distutils\misc_util.py", 
line 723, i
n get_subpackage
    caller_level = caller_level + 1)
  File "c:\python24\Lib\site-packages\numpy\distutils\misc_util.py", 
line 670, i
n _get_configuration_from_setup_py
    config = setup_module.configuration(*args)
  File ".\Lib\setup.py", line 7, in configuration
    config.add_subpackage('integrate')
  File "c:\python24\Lib\site-packages\numpy\distutils\misc_util.py", 
line 740, i
n add_subpackage
    caller_level = 2)
  File "c:\python24\Lib\site-packages\numpy\distutils\misc_util.py", 
line 723, i
n get_subpackage
    caller_level = caller_level + 1)
  File "c:\python24\Lib\site-packages\numpy\distutils\misc_util.py", 
line 670, i
n _get_configuration_from_setup_py
    config = setup_module.configuration(*args)
  File "Lib\integrate\setup.py", line 11, in configuration
    blas_opt = get_info('blas_opt',notfound_action=2)
  File "c:\python24\Lib\site-packages\numpy\distutils\system_info.py", 
line 256,
 in get_info
    return cl().get_info(notfound_action)
  File "c:\python24\Lib\site-packages\numpy\distutils\system_info.py", 
line 397,
 in get_info
    self.calc_info()
  File "c:\python24\Lib\site-packages\numpy\distutils\system_info.py", 
line 1223
, in calc_info
    atlas_version = get_atlas_version(**version_info)
  File "c:\python24\Lib\site-packages\numpy\distutils\system_info.py", 
line 1085
, in get_atlas_version
    library_dirs=config.get('library_dirs', []),
  File 
"c:\python24\Lib\site-packages\numpy\distutils\command\config.py", line 1
01, in get_output
    self._check_compiler()
  File 
"c:\python24\Lib\site-packages\numpy\distutils\command\config.py", line 3
4, in _check_compiler
    old_config._check_compiler(self)
  File "c:\python24\lib\distutils\command\config.py", line 107, in 
_check_compil
er
    dry_run=self.dry_run, force=1)
  File "c:\python24\Lib\site-packages\numpy\distutils\ccompiler.py", 
line 331, i
n new_compiler
    compiler = klass(None, dry_run, force)
  File "c:\python24\lib\distutils\msvccompiler.py", line 211, in __init__
    self.__macros = MacroExpander(self.__version)
  File "c:\python24\lib\distutils\msvccompiler.py", line 112, in __init__
    self.load_macros(version)
  File "c:\python24\lib\distutils\msvccompiler.py", line 133, in load_macros
    raise DistutilsPlatformError, \
distutils.errors.DistutilsPlatformError: The .NET Framework SDK needs to 
be inst
alled before building extensions for Python.






More information about the SciPy-user mailing list