[SciPy-user] gfortran, ifc, compat-g77

Nils Wagner nwagner at mecha.uni-stuttgart.de
Wed Mar 1 03:39:14 CST 2006


Hi all,

It seems to me that installing numpy/scipy on SuSE10.0 is not
straightforward in contrast
to prior versions.

If I remove compat-g77 and try to rebuild numpy from scratch the ifc is
used.
I thought that gfortran will be used  in that case.
Am I missing something ?

Anyway

python setup.py build results  in

 ld: skipping incompatible build/temp.linux-x86_64-2.4/libfblas_src.a
when searching for -lfblas_src
ld: cannot find -lfblas_src
ld: skipping incompatible build/temp.linux-x86_64-2.4/libfblas_src.a
when searching for -lfblas_src
ld: cannot find -lfblas_src
error: Command "/opt2/intel/compiler70/ia32/bin/ifc -shared
build/temp.linux-x86_64-2.4/numpy/core/blasdot/_dotblas.o
-Lbuild/temp.linux-x86_64-2.4 -lfblas_src -o
build/lib.linux-x86_64-2.4/numpy/core/_dotblas.so" failed with exit status 1
 

Nils

Is there someone on the list who has successfully installed numpy/scipy
with or without ATLAS using SuSE 10.0 ?

http://www.novell.com/products/linuxpackages/professional/compat-g77.html



More information about the SciPy-user mailing list