[SciPy-user] scipy.test problem

Brett Olivier bgoli at sun.ac.za
Fri Mar 17 08:29:23 CST 2006


Hi Matthew

On Friday 17 March 2006 14:50, Matthew Brett wrote:
> I suppose there must be something wrong with the compilation of lapack
> or ATLAS then.  Maybe a problem with 3.7.11.  Etc etc.  Dammit, what a
> way to spend your day.

Just out of interest, what compiler options are you using to build LAPACK and 
ATLAS? On the 64 bit P4 I use for LAPACK (in make.inc): 

OPTS     = -funroll-all-loops -O3 -m64 -fno-second-underscore  -fPIC
NOOPT    = -m64 -fno-second-underscore -fPIC

and if I remember correctly, for ATLAS 3.7.11 I added (to Make.<arch> after 
ATLAS configuration): 
-fPIC and -m64 to various compiler options.

All compiled with gcc/g77 3.4.3.
Brett

> Incidentally, scipy.test(10) still dies at scipy.linalg with:
>
>            Finding matrix determinant
>       ==================================
>
>       |    contiguous     |   non-contiguous
>
> ----------------------------------------------
>  size |  scipy  | basic   |  scipy  | basic
>    20 |   0.20  |   0.28  |   0.23  |   0.30     (secs for 2000 calls)
>   100 |   0.32  |   0.45  |   0.38  |   0.53     (secs for 300 calls)
>   500Illegal instruction
>
> This error does not occur with my home-compiled atlas libraries.  AMD
> specific compile for Ubuntu atlas maybe?
>
> Best,
>
> Matthew
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-user



More information about the SciPy-user mailing list