[SciPy-user] mpi4py instalation.

fiepye at atlas.cz fiepye at atlas.cz
Thu Nov 2 12:26:41 CST 2006


Hello.

Thank you all, who responded to my posted question

http://projects.scipy.org/pipermail/scipy-user/2006-October/009705.html

I have got python2.4.3. I downloaded ipython, open mpi and mpi4py. 

Before instalation I configured Open MPI by the following line

./configure --prefix=/usr/local/mpi/open-mpi --with-threads=posix --enable-mpi-threads --enable-progress-threads

later by

./configure --prefix=/usr/local/mpi/open-mpi --with-threads=posix --enable-mpi-threads

mpi4py was cofigured by

python2.4 setup.py config --mpicc=/usr/local/mpi/open-mpi/bin/mpicc

After instalation, whern running python2.4 or ipython and loading mpi4py modul 

from mpi4py import *

I got the following message:

[juniper:04298] *** An error occurred in MPI_Errhandler_free
[juniper:04298] *** on communicator MPI_COMM_WORLD
[juniper:04298] *** MPI_ERR_ARG: invalid argument of some other kind
[juniper:04298] *** MPI_ERRORS_ARE_FATAL (goodbye)
[juniper:04298] [0,0,0] ORTE_ERROR_LOG: Not found in file base/pls_base_proxy.c at line 189

and python crashed.

Could anybody help me?

Fie Pye





More information about the SciPy-user mailing list