[SciPy-user] Another OS X issue

Robert Kern robert.kern at gmail.com
Tue Nov 7 13:26:01 CST 2006


Anand Patil wrote:
> Hi everyone,
> 
> I had installed scipy from the installer packages available on the 
> website, then installed numpy 1.0 when it came out, and then scipy 
> didn't work. Now I'm having a bit of trouble compiling scipy from source:
> 
> /usr/bin/ld: can't locate file for: -lcc_dynamic
> collect2: ld returned 1 exit status
> /usr/bin/ld: can't locate file for: -lcc_dynamic
> collect2: ld returned 1 exit status
> error: Command "/sw/bin/g77 -g -Wall -undefined dynamic_lookup -bundle 
> build/temp.macosx-10.4-fat-2.4/build/src.macosx-10.4-fat-2.4/Lib/fftpack/_fftpackmodule.o 

> I'm on a PowerBook G4 running Tiger.

You cannot use gcc 4.0 with g77, and you need to use gcc 4.0 to build Universal
binaries for the Python that you are using. You need to use gfortran with gcc 4.0.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
 that is made terrible by our own mad attempt to interpret it as though it had
 an underlying truth."
  -- Umberto Eco


More information about the SciPy-user mailing list