[SciPy-user] Another OS X issue

Anand Patil anand at soe.ucsc.edu
Wed Nov 8 12:32:35 CST 2006


Sorry about the hassle:

$ sudo python setup.py config_fc --fcompiler=gfortran install

...

error: don't know how to compile Fortran code on platform 'posix' with 
'gfortran' compiler. Supported compilers are: 
compaq,none,absoft,intel,f,gnu,sun,nag,vast,ibm,gnu95,intelv,g95,intele,pg,lahey,compaqv,mips,hpux,intelev,intelem)

$ python -c 'import os,sys;print os.name,sys.platform'
posix darwin

$ python -c 'import sys;print sys.version'
2.4.3 (#1, Apr  7 2006, 10:54:33)
[GCC 4.0.1 (Apple Computer, Inc. build 5250)]

> You cannot use gcc 4.0 with g77, and you need to use gcc 4.0 to build Universal
> binaries for the Python that you are using. You need to use gfortran with gcc 4.0




More information about the SciPy-user mailing list