[SciPy-user] [Pythonmac-SIG] In need of an OS 10.4.8-compatible Universal binary built w/ gcc 3.3 (NOT 4.0)

David Goldsmith David.L.Goldsmith at noaa.gov
Tue Nov 14 01:20:22 CST 2006


Ronald Oussoren wrote:
>
> On  14 Nov 2006, at 8:10 AM, David Goldsmith wrote:
>
>> Ronald Oussoren wrote:
>>>
>>> On  13 Nov 2006, at 11:59 PM, Robert Kern wrote:
>>>
>>>> David L Goldsmith wrote:
>>>>> Hi!  I'm experiencing a problem with scipy; its install notes say
>>>>> that it is not yet fully compatible with OSX and further say that 
>>>>> in OSX
>>>>> one should ensure that one's gcc selection is set to 3.3.  Mine 
>>>>> is, but
>>>>> I noticed that the Universal build Python binary I downloaded and am
>>>>> using was built w/ gcc 4.0.1.  Accordingly, I suspect this might 
>>>>> be the
>>>>> basis of my problem - any idea where I might obtain an OSX-compatible
>>>>> Python built w/ gcc 3.3?  Thanks!
>>>>
>>>> You can't do it. Universal binary capability was only added to gcc 
>>>> 4.0.
>>>>
>>>> You are looking at somewhat old instructions. While there are still 
>>>> some
>>>> problems with gfortran (which only supports gcc 4.0 rather than g77 
>>>> with only
>>>> supports gcc 3.x), they are few and minor.
>>>>
>>>> Install a gfortran binary from this page:
>>>>
>>>>   http://hpc.sourceforge.net
>>>>
>>>> Then build scipy using --fcompiler=gnu95
>>>
>>> And don't forget to reset your gcc selection to 4.x.
>> Is there a different way to do this, 'cause when I try:
>>
>>    gcc_select 4, 4.0, or 4.0.1
>>
>> I get:
>>
>>    usage: gcc_select [-n] [-force] [2 | 3 | 3.x] [-h | --help] [-v | 
>> --version]
>>                  [-l | --list] [-root]
>>       Invalid argument (4.0.1)
>>
>> Does this mean I now have to download and install gcc 4.0.1?
>
> What version of Xcode do you use? On my system:
I'm not using Xcode, I'm doing all this in a terminal.

DG



More information about the SciPy-user mailing list