[SciPy-user] umfpack and building scipy from source

Robert Cimrman cimrman3 at ntc.zcu.cz
Thu Nov 30 03:58:29 CST 2006


Ryan Krauss wrote:
> I am trying to build scipy/numpy from source on Windows XP.  I do not
> have umfpack installed.  When I build scipy I get this warning:
> 
> C:\Python24\lib\site-packages\numpy\distutils\system_info.py:401: UserWarning:
>     UMFPACK sparse solver (http://www.cise.ufl.edu/research/sparse/umfpack/)
>     not found. Directories to search for the libraries can be specified in the
>     numpy/distutils/site.cfg file (section [umfpack]) or by setting
>     the UMFPACK environment variable.
>   warnings.warn(self.notfounderror.__doc__)
> 
> numpy.test() runs without problems.  The output of scipy.test() is
> slightly scary:
> 
> scipy.test()
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
>   Found 397 tests for scipy.ndimage
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> Warning: FAILURE importing tests for <module 'scipy.sparse.sparse'
> from '...ckages\\scipy\\sparse\\sparse.pyc'>
> C:\Python24\Lib\site-packages\scipy\linsolve\_superlu.py:2:
> ImportError: numpy.core.multiarray failed to import (in ?)
> Warning: FAILURE importing tests for <module 'scipy.optimize.optimize'
> from '...es\\scipy\\optimize\\optimize.pyc'>
> C:\Python24\Lib\site-packages\scipy\optimize\minpack.py:6:
> AttributeError: 'module' object has no attribute 'error' (in ?)
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> Warning: FAILURE importing tests for <module
> 'scipy.linsolve.umfpack.umfpack' from
> '...y\\linsolve\\umfpack\\umfpack.pyc'>
> C:\Python24\Lib\site-packages\scipy\linsolve\_superlu.py:3:
> ImportError: numpy.core.multiarray failed to import (in ?)
> RuntimeError: module compiled against version 1000002 of C-API but
> this version of numpy is 1000009
> Warning: FAILURE importing tests for <module 'scipy.linsolve.umfpack'
> from '...\\linsolve\\umfpack\\__init__.pyc'>
> C:\Python24\Lib\site-packages\scipy\linsolve\_superlu.py:4:
> ImportError: numpy.core.multiarray failed to import (in ?)
>   Found 95 tests for scipy.sparse
>   Found 0 tests for __main__
> .............................................................................................................................................................................................................................................................................................................................................................................................................EEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE...E.EE.......EEE..EE.EE.E.EEEEEEEE.EEE.E.E.E
> ======================================================================
> ERROR: check_eye (scipy.tests.test_sparse.test_construct_utils)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "C:\Python24\Lib\site-packages\scipy\sparse\tests\test_sparse.py",
> line 626, in check_eye
>     a = speye(2, 3 )
>   File "C:\Python24\Lib\site-packages\scipy\sparse\sparse.py", line
> 2833, in speye
>     return spdiags(diags, k, n, m)
>   File "C:\Python24\Lib\site-packages\scipy\sparse\sparse.py", line
> 2811, in spdiags
>     diagfunc = eval('sparsetools.'+_transtabl[mtype]+'diatocsc')
>   File "<string>", line 0, in ?
> AttributeError: 'module' object has no attribute 'ddiatocsc'
> 
 > ....
> 
> What have I done wrong?  I did not try to build Atlas/Blas/Lapack from
> source but just down loaded the precomipled versions into
> C:\BlasLapackLibs.  My scipy and numpy svn folders are not on my PATH
> or my PYTHONPATH.  I had some trouble getting numpy's setup.py to find
> the atlas, lapack, blas libs until I set an ATLAS environment
> variable.

Ryan,

it seems you try to run scipy with different version of numpy than it 
was compiled with. did you try removing existing installation and 
rebuilding all sources?

Anyway missing umfpack would not cause all those errors.

> Oh, and the example site.cfg mentions libamd.a as well as umfpack.  Do
> I need the amd lib?  I am running an amd processor under windows
> (Athlon X2).

libamd.a has nothing to do with the amd processors - it it a library (a 
part of umfpack-related package) for ordering a sparse matrix prior to 
Cholesky factorization (http://www.cise.ufl.edu/research/sparse/amd/) 
and you do not need it if you do not use umfpack.

r.


More information about the SciPy-user mailing list